End-of-support for Windows PowerShell 2

Following the end of support of Windows Server 2008 R2, in March 2020 we announced that we require Windows PowerShell 3.0+ and .NET Framework 4.5+ as prerequisite for all new releases of AWSPowerShell.

As of June 1st, 2020 we no longer release new AWSPowerShell versions compatible with Windows PowerShell 2. The existing versions of AWSPowerShell that are compatible with Windows PowerShell 2 and .NET Framework 3.5 will continue to be available for download from PowerShell Gallery, but will not be updated or supported.